优下载 - 用心为网友精心挑选每一款电脑软件-WWW.YOOXZ.COM

当前位置:首页 > 系统教程 > Linux教程 > 详细页面

Linux安装第三方库时报错Python version 2.7怎么办?

时间:2018-07-09来源:优下载作者:qipeng 阅读: 6 次

  Linux系统用户在安装第三方库的时候,突然提示错误代码Python version 2.7 required,which was not found in the registry,遇到这个问题的时候你只需建立一个脚本并执行,即可解决这个问题。

Linux安装第三方库时报错Python version 2.7怎么办?

  建立一个文件 register.py 内容如下。 然后执行该脚本

  代码如下

  import sys

  from _winreg import *

  # tweak as necessary

  version = sys.version[:3]

  installpath = sys.prefix

  regpath = “SOFTWARE\Python\Pythoncore\%s\” % (version)

  installkey = “InstallPath”

  pythonkey = “PythonPath”

  pythonpath = “%s;%s\Lib\;%s\DLLs\” % (

  installpath, installpath, installpath

  )

  def RegisterPy():

  try:

  reg = OpenKey(HKEY_CURRENT_USER, regpath)

  except EnvironmentError as e:

  try:

  reg = CreateKey(HKEY_CURRENT_USER, regpath)

  SetValue(reg, installkey, REG_SZ, installpath)

  SetValue(reg, pythonkey, REG_SZ, pythonpath)

  CloseKey(reg)

  except:

  print “*** Unable to register!”

  return

  print “--- Python”, version, “is now registered!”

  return

  if (QueryValue(reg, installkey) == installpath and

  QueryValue(reg, pythonkey) == pythonpath):

  CloseKey(reg)

  print “=== Python”, version, “is already registered!”

  return

  CloseKey(reg)

  print “*** Unable to register!”

  print “*** You probably have another Python installation!”

  if __name__ == “__main__”:

  RegisterPy()

  上面就是Linux安装第三方库报错的解决方法了,上文就是该脚本的代码,执行脚本后再安装第三方库就不会出现错误代码了。


系统教程栏目

栏目热门教程

人气教程排行

站长推荐

热门系统下载

公众号